Agent trace log files not rolling over per the configured settings
search cancel

Agent trace log files not rolling over per the configured settings

book

Article ID: 411802

calendar_today

Updated On:

Products

SITEMINDER

Issue/Introduction

Agent trace logs are not rolling over per the configured parameters.

If the web server service is restarted, then the logs roll over.

Environment

Version: 12.8.x - 12.9.x
OS: Windows Server

Cause

This can be caused when two agents, using the same ACO are writing to the same log file.

This can be identified by looking in Resource Monitor (Task Manager > Performance > Resource Monitor > CPU > Associated Handles) and searching for the name of the log file.

When the issue is occurring, you the results will look like this:



You will find two java.exe processes with the same PID for the same log file name.

Resolution

Create a new ACO and point one of the agents to a new log file.