Agent trace log files not rolling over per the configured settings?
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Agent trace log files not rolling over per the configured settings?

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Article ID: 411802

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Updated On:

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Issue/Introduction

Agent trace logs are not rolling over per the configured parameters.

If the web server service is restarted, then the logs roll over.

Environment

Version: 12.8.x and 12.9 (Applicable to all the supported releases)
Operating System: Windows Server

Cause

This can be caused when two agents, using the same ACO, are writing to the same log file.

This can be identified by looking in Resource Monitor (Task Manager > Performance > Resource Monitor > CPU > Associated Handles) and searching for the name of the log file.

When the issue is occurring, the results will look like this:



Two " java.exe " processes with the same PID for the same log file name will be shown.

Resolution

Create a new ACO and point one of the agents to a new log file.