Site Recovery UI reports error "The Host Based Replication Agent for ESX can't be installed"
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Site Recovery UI reports error "The Host Based Replication Agent for ESX can't be installed"

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Article ID: 411800

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Updated On:

Products

VMware Live Recovery VMware Cloud Foundation

Issue/Introduction

  • HBR agent can’t be installed on the vLCM cluster automatically. Site Recovery UI reports below errors.
    1. The Host Based Replication Agent for ESX can't be installed on 'cluster-XXX’. Live Patch is enforced and needs to be disabled in vLCM policies.
    2. The Host-Based Replication Agent for ESX can't be installed on 'host-XXX’. The vLCM image has deltas that need to be applied.

Environment

  • VMware Cloud Foundation 9.0.1
  • VMware Live Recovery 9.0.4
  • vSphere Replication 9.0.4

Cause

  • Host Based Replication agent is part of a vSphere Replication component which is installed on the ESXi hosts to track and transmit changes on a VM from source to destination site.
  • Starting VLR 9.0.4(ESXi 9.0.1 Maintenance), HBR agent install/upgrade in ESXi host through vLCM cluster doesn’t place the host in maintenance mode.
  • However, the HBR agent will not be installed on the host, if vLCM cluster has “Enforce Live Patch” enabled or the cluster compliance check finds other drifts on the hosts except HBR agent. 

Resolution

  • HBR agent install through vLCM clusters needs “Enforce Live Patch” to be disabled in the cluster and the hosts should not report any other deltas apart from HBR VIB in the compliance check.
  • Please follow below steps based on the error received in the Site Recovery UI


1.   Ensure vLCM does not have “Enforce Live Patch” enabled in the vLCM remediation policy. 

    • Login the vCenter by using vSphere Web Client. Click on the Lifecycle Manager plugin.
    • Click on Settings. On the left pane, under Cluster lifecycle, select Images.
    • Click on Edit and uncheck Enforce Live Patch option.

2.  'Enforce Live Patch' must be disabled at Cluster level Remediation Settings if modified at cluster level.

    • Login the vCenter by using vSphere Web Client. Select Cluster in Inventory.
    • Click Updates tab.
    • Click '...' next to 'CHECK COMPLIANCE' button.
    • Click 'Edit remediation settings'
    • Disable 'Enforce Live Patch if enabled

3.  Validate and fix the other deltas reported by compliance check before vLCM installs the HBR agent on the host.

    • Login the vCenter by using vSphere Web Client. Click on cluster, then go the Updates tab.
    • Under Hosts, click on Image. Run the CHECK COMPLIANCE under Image Compliance.
    • Validate the deltas for each host in the cluster. If there are any deltas other than HBR agent, fix the deltas for the hosts.
    • Once deltas are fixed, run CHECK COMPLIANCE again to ensure it is only the HBR VIB for each host in the cluster.

Additional Information

  • In vSphere Replication 8.7, 8.8 upto 9.0.2 releases, post vSphere Replication appliance upgrade, ESXi hosts enters maintenance mode by VLCM (VMware Life Cycle Manager) during hbr-agent VIB push.
  • For workaround, please refer KB 389735 & KB 87487
  • This issue is not observed when running on VCF 4.x or VCF 5.x since VMware Update Manager manages the updates, and it uses Baseline mode.
  • This issue is not observed even after moving to vLCM, but if you are still using Baseline mode - However, you will receive alerts on the vCenter server and vSAN Skyline health, prompting to move to a single image mode.