ESXi hosts status is Unknown in NSX UI due to opsAgent crash
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ESXi hosts status is Unknown in NSX UI due to opsAgent crash

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Article ID: 411733

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX UI shows ESXi hosts with status Unknown.
  • Affected ESXi hosts created opsAgent zdump files: /var/core/opsAgent-zdump.###
  • During heavy load, multiple ESXi hosts may be affected in batches.
  • The zdump content shows that boost::uuids::random_generator()() throws an exception boost::uuids::entropy_error

Environment

VMware NSX 9.x
VMware NSX 4.x
VMware NSX-T Data Center 3.x

Cause

This issue may occur if ESXi host entropy is exhausted on the ESXi host.

Resolution

This is a known issue impacting VMware NSX.

Workaround:

  • To recover the connection on the ESXi host:
    /etc/init.d/nsx-opsagent restart
  • To reduce the probabilty of the issue reoccuring:
    • Inspect the sources configured to provide entropy:
      esxcli system settings kernel list -o entropySources
    • Enable additional and/or tune the sources of entropy.
      Please refer to the ESXi documentation: Controlling ESXi Entropy
      For example, to enable all sources:
      esxcli system settings kernel set -s entropySources -v 0xF 
      Or, to enable interrupts and the entropyd daemon (1+8):
      esxcli system settings kernel set -s entropySources -v 9
      Note: A reboot is required for the ESXi host to use the adjusted configuration.