Agents show as not reporting even though they have a recent update time and Error "ORA-2396" in the monitor controller logs
search cancel

Agents show as not reporting even though they have a recent update time and Error "ORA-2396" in the monitor controller logs

book

Article ID: 411641

calendar_today

Updated On:

Products

Data Loss Prevention Enterprise Suite

Issue/Introduction

Agents appear to check in and get updates, but they show as disconnected in the console. 

After reviewing the monitor controller log file on Enforce, there are many ORA-2396 errors.

Environment

16.0.x

16.1

Cause

SQL connections to the database are timing out.

Resolution

ORA-2396 is caused by the Oracle IDLE_TIME setting being configured to be too low. Work with the DBA to configure this setting to be unlimited. Once configured restart Oracle services then the Enforce and Detection server services.