VMs on ESXi standard switch do not communicate
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VMs on ESXi standard switch do not communicate

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Article ID: 411640

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • When attempting to ping from one VM to another VM that are on the same host but in different portgroups the pings are failing. 
  • ESXi Standard Switch VM port group not working after reinstall

Environment

VMware ESXi

Cause

VLAN misconfigurations as well as NIC teaming configurations (NIC to NIC) on the physical network are preventing VM to VM connectivity on a Standard Switch.  

 

Please note that there are other possible causes for VM connectivity issues, however this document focuses on VLAN configuration issues and NIC teaming traffic issues. For more details on other VM connectivity troubleshooting steps, please refer to Troubleshooting virtual machine network connection issues.

Resolution

Performing the processes below can help identify and resolve VM to VM communication issues:

    1. Are the VLANs on the physical switchport configured as trunked, native/access?
    2. Using esxtop, identify what NICs are currently in use by the VMs.
      • Run the command esxtop then hit enter. Then press the letter n to open the networking view. 
      • Locate the VMs in question and make note of which vmnic is currently associated with the VMs.
      • Hit the letter q to quit out of esxtop. 
    3. Review the portgroup configurations for the VMs
      • Are the NICs in use able to pass VM traffic (as well as the VLAN associated with the traffic)?
      • Are there any NICs that are in use by the VMs that cannot pass VM traffic?
      • What is the teaming and failover policy?
    4. Specific VM configurations to consider 
      • If the VMs are Windows VMs, do the pings work if the Microsoft firewall is configured to allow all traffic?
      • Can the VMs pass traffic using different NICs?
        • This can be done if the VMs portgroups have multiple NICs in either an active or standby configuration (and the physical NICs are configured to pass said traffic) by downing the currently in use NIC to force the VM to use another NIC.  
          • For example: an environment has 4 NICs total (vmnic0, vmnic1, vmnic2, and vmnic3). VM A is using vmnic0 and VM B is using vmnic3 but cannot ping each other. If VM A moves to vmnic3 do the pings succeed or still fail?
        • If using new NICs works, then its confirm the physical NIC configuration for which can communicate to other NICs. Please work with the server (physical switch) vendor for assistance on configurations. 
        • If using new NICs fails, and each NIC to NIC test fails (essentially eliminating any NIC to NIC pathing issues) proceed with packet captures to trace the traffic to identify where the packet loss is occurring. To do so, please refer to Packet capture on ESXi using the pktcap-uw tool
    5. If further assistance is needed in diagnosing where the packet loss is occurring, please open a case with Broadcom Support.