NSX alarm "Controller Channel To Transport Node Down" occurring repeatedly.
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NSX alarm "Controller Channel To Transport Node Down" occurring repeatedly.

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Article ID: 411620

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Updated On:

Products

VMware NSX

Issue/Introduction

  • In the NSX Manager UI, the following alarm is seen to trigger repeatedly. 

Event Type
Control Channel To Transport Node Down
Description
Controller service on Manager node 10.###.###.64 (<Mgr UUID>) to Transport node esxi70.example.com (<TN UUID>) down for at least three minutes from Controller service's point of view.
Recommended Action
1. Check the connectivity from the Controller service <Mgr UUID> and Transport node <TN UUID> interface via ping and traceroute. This can be done on the NSX Manager node admin CLI. The ping test should not see drops and have consistent latency values. VMware recommends latency values of 150ms or less. 2. Navigate to System | Fabric | Nodes | Transport node <TN UUID> on the NSX UI to check if the TCP connections between the Controller service on Manager node 10.###.###.64 (<Mgr UUID>) and Transport node <TN UUID> is established. If not, check firewall rules on the network and the hosts to see if port 1235 is blocking Transport node <TN UUID> connection requests. Ensure that there are no host firewalls or network firewalls in the underlay are blocking the required IP ports between Manager nodes and Transport nodes. This is documented in our ports and protocols tool which is here: https://ports.vmware.com/.

Environment

VMware NSX

Cause

This alarm indicates the NSX Manager Controller service connection to the Transport node is detected as down. 

Resolution

  • Anything that causes an interruption in the communication channel between the NSX Managers and the NSX-prepared ESXi transport nodes can cause this alarm to trigger.
    • This includes rebooting the NSX-prepared ESXi transport node repeatedly. 

For additional troubleshooting steps regarding this alarm see Control Channel To Transport Node Down Alarm.