Issues are not resolved after applying Clarity Patch
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Issues are not resolved after applying Clarity Patch

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Article ID: 411607

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After applying Clarity patch, and testing the defects included, the defect fixes are not included. If we check the Clarity - About, the build version for Classic is correct and the install log has no errors.

Environment

All Supported Clarity Releases

Cause

MUX war not redeployed correctly as services were not correctly redeployed

Resolution

  • Best practice is to always stop and remove services before applying a Clarity patch, then adding and deploying them back 
  • Go to Clarity MUX - About and note the Modern User Experience Build Number
  • This has to be updated after applying any Clarity patch and you can compare to another environment with the same patch version

Workaround:

  1. Connect to the Clarity server
  2. Stop and remove services with command:
    • service stop remove all
  3. Add the services, deploy back and start (adjust the service names accordingly if needed):
    • service add app bg nsa beacon
    • service deploy start all