DSM integration with VCF Automation 9.0 fails and failed connection fails to clean up on delete
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DSM integration with VCF Automation 9.0 fails and failed connection fails to clean up on delete

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Article ID: 411533

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Updated On:

Products

VMware Data Services Manager for VCF

Issue/Introduction

On following the steps to configure Data Services Manager with VMware Cloud Foundation Automation 9.0 (Configure VMware Data Services Manager in VMware Cloud Foundation Automation), the connection fails.

A connection is reported with "unhealthy" status.

Deletion of the connection hangs.

An error may be reported similar to:

Execution of behavior urn:vcloud:behavior-interface:notify:broadcom:dsm:9.0.0 on entity urn:vcloud:entity:broadcom:dsm:########-####-####-####-############VCFA - Reconciliation after deleting DSM Service
failed. Details: Error: not found VCFA refresh token of service account 




Environment

VMware Data Service Manager 9.0

Cause

This issue arises if an incorrect certficate is added when providing the DSM details.

Resolution

Please open a Broadcom Support case for assistance.