DLP Upgrade Cannot Access Network Location Error
search cancel

DLP Upgrade Cannot Access Network Location Error

book

Article ID: 411494

calendar_today

Updated On:

Products

Data Loss Prevention Core Package

Issue/Introduction

When customer is upgrading from DLP 15.8 (and possibly other versions) they encounter the error "Cannot access network location DetectionServer\15.8.00000\Protect\Scanners" as per the below screenshot when they attempt to run the msi to install the new version of DLP. This can occur on the detection servers and/or enforce server.

The following errors may also be observed in the msi verbose uninstall log.

MSI (s) (28:54) [07:37:42:821]: Note: 1: 1314 2: DetectionServer\15.8.00000\Protect\Scanners 
MSI (s) (28:54) [07:37:42:821]: Note: 1: 1606 2: DetectionServer\15.8.00000\Protect\Scanners 
MSI (s) (28:54) [07:37:42:821]: Note: 1: 2205 2:  3: Error 
MSI (s) (28:54) [07:37:42:821]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1606 
MSI (s) (28:54) [07:37:42:821]: Note: 1: 2205 2:  3: Error 
MSI (s) (28:54) [07:37:42:821]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709 
MSI (s) (28:54) [07:37:42:821]: Product: Symantec Data Loss Prevention 15.8.00000 MP3 HF18 Detection Server -- Error 1606. Could not access network location DetectionServer\15.8.00000\Protect\Scanners.

MSI (s) (28:54) [07:37:42:821]: Note: 1: 1606 2: DetectionServer\15.8.00000\Protect\Scanners 
MSI (s) (28:54) [07:37:42:821]: Note: 1: 2205 2:  3: Error 
MSI (s) (28:54) [07:37:42:821]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1606 
Error 1606. Could not access network location DetectionServer\15.8.00000\Protect\Scanners.
MSI (s) (28:54) [07:37:42:821]: Note: 1: 2205 2:  3: Error 
MSI (s) (28:54) [07:37:42:821]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709 
MSI (s) (28:54) [07:37:42:821]: Product: Symantec Data Loss Prevention 15.8.00000 MP3 HF18 Detection Server -- Error 1606. Could not access network location DetectionServer\15.8.00000\Protect\Scanners.

 

Cause

It has been determined that this is primarily caused by a missing registry key for the 15.8 install, the exact cause of this is unknown but may be related to a previous rollback of the software after a failed upgrade attempt.

Resolution

The customer must restore/replace the missing registry below key and then run the msi again.

HKLM\SOFTWARE\Symantec\Data Loss Prevention\Detection Server\15.8.00000\Installation

Manually adding this entry should allow the upgrade to complete successfully.