vSAN File Service Modules in vCenter reporting error "Unable to extract requested data. Check vSphere Client logs for details."
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vSAN File Service Modules in vCenter reporting error "Unable to extract requested data. Check vSphere Client logs for details."

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Article ID: 411416

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Updated On:

Products

VMware vSAN

Issue/Introduction

  • vSAN File Service Modules in vCenter reporting error "Unable to extract requested data. Check vSphere Client logs for details."
  • File Shares (NFS/SMB) are down and can not be accessed 
     



  • The FSVMs will be in a failover loop and look like they're trying to upgrade, however this issue is not specific to an environment upgrade.
  • In vdfs-server.log from one or more hosts the below messages are seen for one or more objects:

    2025-09-08T11:50:55.245Z|f-3-000000005|GENCHUNK: ce40d862-9275-e7bc-76ab-############: Freeing a block already free'd: 6796: 2, Recovery: 0
    2025-09-08T11:50:55.245Z|f-3-000000005|GENCHUNK: ce40d862-9275-e7bc-76ab-############: Freeing a block already free'd: 6796: 3, Recovery: 0
    2025-09-08T11:50:55.347Z|f-3-000000005|GENCHUNK: ce40d862-9275-e7bc-76ab-############: Freeing a block already free'd: 6505: 3, Recovery: 0

Environment

VMware vSAN 8.x
vSAN File Services

Cause

Under certain rare conditions, snapshot deletion of a share may result in the File Share VMs to crash and fail to recover.

Resolution

This has been fixed in 8.0P07 (8.0U3h). Upgrade vCenter/ESXi to 8.0U3h  

Open a case with vSAN Support for assistance to remediate the issue if encountered