Devices incorrectly assigned the wrong origin
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Devices incorrectly assigned the wrong origin

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Article ID: 411397

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Storage team devices continue to have the wrong origin assigned. We need clear guidance on the actions required to prevent these devices from receiving the wrong origin, and specifically to avoid an R&D environment's hub origin being assigned.

Environment

  • DX UIM 23.4 CU3
  • vmware probe v7.23

Cause

  • qos_processor not working as expected

Resolution

qos_processor, the probe which handles origin changes, showed tons of these messages in the log:
"failed to enqueue pending qos object"
Steps followed:
  1. Open "Raw Configure" on the qos_processor probe.
  2. Navigate into the "setup" folder/section.
  3. Click "New Key..."
  4. Add a new key called: database-update-queue-capacity
  5. Set a value for this key of 20000  (the default value is 10000, so doubling it is a good place to start.)
  6. If the error message persists after this, you may need to set the value even higher, such as 50000.

The qos_processor may consume more memory with this value increased, so it is a good idea to increase the allocated memory for the probe as well.  To do so:

  • Use "Raw Configure" on the qos_processor probe
  • Navigate to the "startup" folder, then "opt" underneath that.
  • Increase the value set for "java_mem_max" here.  It may be advisable to monitor the probe's memory usage and set the value according to your own observations.

Additional Information

To correct the incorrectly-assigned origins in your existing collected QOS you can follow this KB Article:

Update or change origins for QOS data in DX UIM