VCF Automation 9 Installation through Fleet management is getting failed with error "LCMVMSP10002"
search cancel

VCF Automation 9 Installation through Fleet management is getting failed with error "LCMVMSP10002"

book

Article ID: 411354

calendar_today

Updated On:

Products

VCF Automation

Issue/Introduction

  • VCF Automation 9 Installation through Fleet management is getting failed with error "LCMVMSP10002"
  • The deployment is failing with the following task - Deploy package task - Error Code: LCMVMSP10002

    com.vmware.vrealize.lcm.vmsp.common.exception.DeploymentFailedException: No failed pods found.No failed pods found.    at com.vmware.vrealize.lcm.vmsp.plugin.tasks.VmspPkgPushTask.execute(VmspPkgPushTask.java:78)    at com.vmware.vrealize.lcm.vmsp.plugin.tasks.VmspPkgPushTask.retry(VmspPkgPushTask.java:114)    at com.vmware.vrealize.lcm.automata.core.TaskThread.run(TaskThread.java:60)    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)    at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)    at java.base/java.lang.Thread.run(Unknown Source)

  • The following error is seen on VCFOPs >> Administration >> Control Panel >> Support logs , under the VCOPS_BRIDGE >> vcops-bridge.log 

    Caused by: javax.net.ssl.SSLPeerUnverifiedException: Host name 'Fleet-Management-FQDN' does not match the certificate subject provider
    (210501
    at org.apache.http.conn.ssl.SSLConnectionSocketFactory.verifyHostname(SSLConnectionSocketFactory-java:465) ~[httpclient-4.5.jar:4.5l
    (21051]

  • Under VCF Operations > Fleet Management, the Certificates/Passwords section within VCF Management returns a 'No Data Found' error.

Environment

VCF Operations 9.x
VCF Fleet Management 9.x

Cause

This issue occurs when the VCF Fleet certificate is replaced using an incorrect Subject Alternative Name (SAN) entry.

Resolution

To resolve this issue, follow the below steps:

  1. Generate a new VCF Fleet certificate with right SAN entry and Replace the old VCF Fleet certificate with the new one.

  2. Make sure the Fleet Management is "Connected" on VCF Operations admin UI (https://VCF-OPerations FQDN/admin).

  3. Verify that the Certificates and Passwords sections under VCF Operations > Fleet Management are correctly populating with data.

  4. Retry the VCF Automation deployment from Fleet Management.