Control Plane Upgrade Fails Due to FQDN Resolution Issue for Data Services Manager (DSM) Provider Backup Location
search cancel

Control Plane Upgrade Fails Due to FQDN Resolution Issue for Data Services Manager (DSM) Provider Backup Location

book

Article ID: 411329

calendar_today

Updated On:

Products

VMware Data Services Manager

Issue/Introduction

When DSM is configured with a provider backup repository that uses a Fully Qualified Domain Name (FQDN) for its address, the Control Plane (CP) upgrade process may fail.

 

Environment

VMware Data Services Manager

Cause

This occurs because the provider-update-service within the Control Plane is unable to resolve the FQDN of the backup repository to a valid IP address.

Resolution

Symptoms:


DSM UI Status:
The "PROVIDER UPDATE" task in the DSM user interface will be marked as Failed.


Log File Error Trace:
Examination of the /var/log/tdm/provider/providerupdatemanager.log file on the Control Plane VM will reveal an error similar to the following:



Caused by: java.net.UnknownHostException: 
<<The specific FQDN configured for your provider backup repository.>>


If the above trace is found in the log file, follow the steps below:


1. Verify current DNS Configuration within the provider-update-service Container:


> SSH to provider vm as root user

> Execute the command to access the provider-update-service Docker container:
     docker exec -u root:root -it provider-update-service bash

> Once inside the container, navigate to /opt/vmware/tdm-provider/update-manager-service directory.

> Display the DNS server configuration by executing: 
      cat /etc/resolv.conf
Check the nameserver entry in the output. This IP address should match the DNS server IP configured in your DSM settings. If it's missing/incorrect/or different from your DSM configured DNS, a restart is required.

> Exit the Docker container



2. Restart the update-manager.service:

         Command:


systemctl restart update-manager.service


         > Verify that status of the services is active :

systemctl status update-manager.service


3. Validate DNS Configuration After Restart:


> Repeat Step 1 to re-enter the provider-update-service Docker container and check the /etc/resolv.conf file again.


> Verify that the nameserver entry now correctly reflects the DNS server IP configured in DSM.



4. Retrigger the Control Plane Upgrade:


Once you have confirmed that the provider-update-service has the correct DNS configuration, re-initiate the Control Plane upgrade process from the DSM UI.

Additional Information

Even after trying these steps, or if your DNS settings already looked correct but the upgrade still failed, please contact Broadcom Support.