Download plug-in failed in vSphere Client with error "Error downloading plug-in"
search cancel

Download plug-in failed in vSphere Client with error "Error downloading plug-in"

book

Article ID: 411268

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Getting the following error in vSphere Client:

Error downloading plug-in. Make sure that the URL is reachable and the registered thumbprint is correct.

Environment

VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.x

Cause

One or more plugins failed to communicate with vCenter Server.

Resolution

  1. On the vSphere Client > Administration > Solutions > Client Plugins page, click the plugin that cannot communicate with vCenter Server.
  2. If the plugin is deprecated, click REMOVE to remove it from vCenter Server.
  3. If the plugin is in use, make sure vCenter Server is able to access its URL:
    • Check if the IP address or FQDN is accessible from vCenter Server
    • Check the plugin Docs to see if it requires access to a specific port on vCenter. If so, verify the connectivity from the plugin admin console to vCenter Server on the port.