Okta Identity Provider Authentication Page is not loading properly
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Okta Identity Provider Authentication Page is not loading properly

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Article ID: 411173

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Updated On:

Products

Symantec ZTNA

Issue/Introduction

ZTNA admin created a number of segment applications that users are to access via managed WSS Agent hosts.

SAML authentication is enabled, and the Identity provider is an Okta IDP server.

All users bar one are challenged for their Okta credentials, login successfully and can access the ZTNA segment applications without a problem.

One user has a problem where the Okta IDP login page is truncated as shown below:

 

Environment

WSS Agent.

SAML Authentication.

ZTNA.

Cloud SWG.

Cause

An older Webview was running on this host. Other applications on the host also integrated with Webview and we assume that an update to another application had caused the issue. 

 

Resolution

Upgraded manually on this host to latest Webview.

 

Additional Information

Webview is responsible for rendering the object returned from the IDP server, and is outside of what the WSS Agent is able to control.