OPS Manager verifiers failing with "Connection failed: 503 Service Unavailable"
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OPS Manager verifiers failing with "Connection failed: 503 Service Unavailable"

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Article ID: 411083

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Updated On:

Products

VMware Tanzu Platform - Cloud Foundry

Issue/Introduction

Apply Changes fails on OPS Manager as it cant complete the IaaS verifiers due to "503 Service Unavailable" error:

"IaaS default: 'Connection failed: 503 \\\"Service Unavailable\\\"', type: PrivilegeVerifier\",
"IaaS default: 'Connection failed: 503 \\\"Service Unavailable\\\"', type: IaasConfigurationVerifier\",
"IaaS default: 'Connection failed: 503 \\\"Service Unavailable\\\"', type: AvailabilityZonesVerifier\",
"'Connection failed: 503 \\\"Service Unavailable\\\"', type: NetworksExistenceVerifier\"],

This is observed in OPS Manager ui and OPS Manager audit logs.

An attempt to create a VM fails as the Bosh Director cant connect to ssl proxy with status 503 Service Unavailable also observed.

 "error": "Unknown CPI error 'Unknown' with message 'connect to ssl proxy failed with status 503 Service Unavailable' in 'create_vm' CPI method

 

Cause

vSphere UI is working as expected when verified via direct connectivity.

However connectivity from OPS Manager and Bosh Director to vSphere is via a HTTP Proxy and it is blocking the connectivity.

Resolution

Review HTTP Proxy configuration in OPS Manager--->Setting (Top right hand)--->Proxy Settings. Confirm no proxy rules are as expected.

Review HTTP Proxy logs to determine why proxy is not allowing connectivity to vSphere.