Agent Upgrade Failing via SCCM / 3rd Party Utility
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Agent Upgrade Failing via SCCM / 3rd Party Utility

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Article ID: 411070

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Agent upgrade is failing via SCCM / 3rd party utilities
  • Upgrade log shows error similar to:
    Attempting to Stop Service[PARITY] CheckpointWait[300000 ms]
    Service[1]: Service is not accepting the stop control code
    ....
    CustomAction b9CA_A_StopParityService returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

Environment

  • App Control Agent: All Supported Versions
  • Microsoft Windows: All Supported Versions

Cause

The allow_upgrade=1 flag was not set.

Resolution

Follow the Upgrades via 3rd Party Utilities steps in the Methods to upgrade the App Control agent article.