SDDC connection to the offline depot fails with error "Failed to connect to VMware Depot with the provided user credentials. Cause: {0}"
search cancel

SDDC connection to the offline depot fails with error "Failed to connect to VMware Depot with the provided user credentials. Cause: {0}"

book

Article ID: 410976

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

  • When connecting to the Offline Depot in the SDDC Manager UI the operation fails with the error "Failed to connect to VMware Depot with the provided user credentials. Cause: {0}"
  • The Offline Depot has been configured as per KB 312168
  • Required bundles have been downloaded using the VCF Download Tool
  • The /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties file on the SDDC Manager looks good as per KB 407405
  • The /var/log/vmware/vcf/lcm/lcm-debug.log shows that a 'HEAD' API call fails with A  404 error which suggests that the requested information cannot be found at the location included in the API call:

1970-01-01T00:00:00.000+0000 DEBUG [vcf_lcm,9fac183655dc48f2,637e] [c.v.e.s.l.b.d.depot.DepotDownloader,http-nio-127.0.0.1-7400-exec-4] Executing HEAD /PROD/COMP/SDDC_MANAGER_VCF/index.v3
1970-01-01T00:00:00.000+0000 DEBUG [vcf_lcm,9fac183655dc48f2,637e] [c.v.e.s.l.b.d.depot.DepotDownloader,http-nio-127.0.0.1-7400-exec-4] Got response: 404 Not Found
1970-01-01T00:00:00.000+0000 ERROR [vcf_lcm,9fac183655dc48f2,637e] [c.v.e.s.l.b.d.depot.DepotDownloader,http-nio-127.0.0.1-7400-exec-4] Error getting file size for /PROD/COMP/SDDC_MANAGER_VCF/index.v3
1970-01-01T00:00:00.000+0000 ERROR [vcf_lcm,9fac183655dc48f2,637e] [c.v.r.i.a.c.d.s.DepotSettingsController,http-nio-127.0.0.1-7400-exec-4] Http error occurred while fetching manifest index [/COMP/SDDC_MANAGER_VCF/index.v3] from <DEPOT_FQDN>:443 with user <DEPOT_USERNAME>
com.vmware.evo.sddc.lcm.model.depot.exception.DepotConnectionFailureException: Internal error while validating credentials
at com.vmware.evo.sddc.lcm.bundle.download.depot.DepotDownloader.validateUser(DepotDownloader.java:367)
at com.vmware.evo.sddc.lcm.bundle.download.depot.DepotBundleDownloadServiceImpl.validateUser(DepotBundleDownloadServiceImpl.java:262)

  • However connectivity between the SDDC Manager and the Offline Depot with the configured Offline Depot credentials has been tested and is good:
  • e.g. a curl test lists expected bundles:

curl -k -u <depot_username>:<depot_user_password> https://<Offline_Depot_FQDN>/COMP/SDDC_MANAGER_VCF/index.v3

d7990026-78a3-4156-bbde-5e2f04275ad7 bundle-130870.manifest
4aac682c-ecf1-4828-acf8-1ceb4662cf9f bundle-133765.manifest
1c145a20-1f19-4393-bec3-b424d12435b5 bundle-133763.manifest
d50ff30-4178-4819-b263-e9f48fbce600 bundle-202281.manifest
ff18cabf-5750-4397-a5da-9f5cb0d476dc bundle-214558.manifest
1836c2da-705c-4119-b5fa-1edba91a7a29 bundle-133760.manifest
dacabb60-58b0-47b6-a995-f42055c85f38 bundle-133766.manifest
39d17140-523a-464f-bf82-bb5e9f3a3375 bundle-133761.manifest
649c709a-b89d-4cab-8b59-2c67326fd7c5 bundle-133764.manifest

 

 

 

Environment

VCF 5.2.x

Cause

  • SDDC UI's HEAD API calls fail due to redundant inclusion of the DocumentRoot's base path (e.g., /PROD) in the request URL.
  • e.g. running the HEAD API manually on the SDDC Manager with the PROD value omitted succeeds:

curl --head -u <depot_username>:<depot_user_password> https://<Offline_Depot_FQDN>/COMP/SDDC_MANAGER_VCF/index.v3

HTTP/1.1 200 OK
Date: Mon, 01 Jan 1970
Server: Apache/2.4.62 (Red Hat Enterprise Linux) OpenSSL/3.2.2
Last-Modified: Mon, 01 Jan 1970
ETag: "###################"
Accept-Ranges: bytes
Content-Length: 736

Resolution

  1. Amend the DocumentRoot path value in the /etc/httpd/conf/httpd.conf file on the Offline Depot webserver to omit the PROD value. For example change DocumentRoot "/data/depot/PROD" to DocumentRoot "/data/depot/" (the /data/depot/ path may differ in your environment)
  2. Restart httpd service: systemctl restart httpd
  3. Retry the depot connection from the SDDC UI.