The NSX Manager GRUB menu is not loading following entering credentials
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The NSX Manager GRUB menu is not loading following entering credentials

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Article ID: 410922

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Updated On:

Products

VMware NSX

Issue/Introduction

When accessing the GRUB menu for an NSX Manager node, such as when changing the root password, the starting menu loads normally. However, after root credentials are applied, the menu returns to the starting menu rather than allowing for access to the authenticated menu.

Starting menu:

Authenticated menu:

Environment

VMware NSX-T

VMware NSX

Cause

The GRUB menu was disabled or improperly configured when the NSX Manager node was deployed, preventing access to the authenticated menu even with correct credentials.

Resolution

NOTE: The following resolution will only work if the existing cluster's admin password is known and current. If the admin password is unknown, please make a case with Broadcom support and reference this KB for assistance.

  1. Power off one of the existing Manager nodes and deploy a new NSX node via OVF with GRUB access with the same node information, such as IP, hostname, etc.
  2. Run the following commands from one of the remaining two nodes still in a cluster, as admin, to get the required cluster details:
    • get cluster config
    • get certificate api thumbprint
  3. After the replacement node has been successfully deployed, remove the old node from the cluster with the following command, replacing old_node_uuid with the UUID of the node being replaced from the get cluster config command above:
    • detach node old_node_uuid
  4. Add the new node to the existing cluster with the below command, replacing existing_node_ip with the IP of one of the two nodes still in the cluster and cluster_id with the cluster UUID, both from the get cluster config command, and api_thumbrint from the get certificate api thumbprint command:
    • join existing_node_ip cluster-id cluster_id thumbprint api_thumbprint username admin
  5. After entering the admin password at the prompt, the new node will be added to the existing cluster and a sync between the nodes will complete.
  6. Verify the sync is complete from the NSX UI: System -> Appliances -> View Details for one of the nodes -> REPO_SYNC status

Once the above steps have been completed, access to the authenticated GRUB menu will be possible via the replaced node.

If the above steps do not resolve the issue, please create a case with Broadcom Support and reference this KB.