Symantec Management Agent service is crashing after agent is installed
search cancel

Symantec Management Agent service is crashing after agent is installed

book

Article ID: 410893

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

After the Symantec Management Agent (SMA or Altiris Agent) is installed on a Windows Server, the Symantec Management Agent service (AeXNSAgent.exe) starts and few seconds later, it stops.
The Agent logs shows errors like this one:

Fatal error occured in module 'AeXNSAgent.exe (8.7.3391.0)' in 'AeXNSAgent.exe'.
Process ID: 29872
Thread ID: 21868
Context Record: 00000064FFFFDA30
Exception Record: 00000064FFFFD990
Exception Code: C0000417
Flags: 00000001
Address: 00007FF698A1F061

RAX=00000064FFFFDA30 RBX=0000000000000000 RCX=00000064FFFFDA30 RDX=0000000000000000 RSI=0000000000000000
RDI=0000000000000000 RBP=0000000000000000 RSP=00000064FFFFDF30 R8 =0000000000000000 R9 =0000000000000000
R10=00007EE1FBBAFA28 R11=00000064FFFFDA30 R12=00000064FFFFE270 R13=0000000000000000 R14=0000000000000000
R15=000000000000000A RIP=00007FF698A1F061 FLG=00000246
CS=0033 DS=002B SS=002B ES=002B FS=0053 GS=002B

Dump file: C:\ProgramData\Symantec\Symantec Agent\CrashDumps\AeXNSAgent_29872_21868_LaptopTest_2025-08-26_17-02-41.ez2
-----------------------------------------------------------------------------------------------------
Date: 8/26/2025 1:03:05 PM, Tick Count: 646857531 (7.11:40:57.5310000), Size: 1.01 KB
Process: AeXAgentUtil.exe (22764), Thread ID: 2284, Module: AeXAgentUtil.exe
Priority: 1, Source: CrashControl

Environment

ITMS 8.7.x, 8.8

Cause

Defect. The crash is caused by the incorrect IIS binding settings. A very unusual scenario.
In this particular issue, somehow the IIS settings end up looking different to this:

http::80:,net.tcp:808:,net.msmq:localhost,msmq.formatname:localhost,net.pipe:*,https::443:

We are expecting that the IIS settings includes protocol, host, port parts delimited by ":".

The issue here is that our SMA expects protocol:host:port format and crashes otherwise. This caused by incorrect IIS bindings string.

Resolution

This issue has been scheduled to be fixed in our next ITMS release: 8.8.1.

 

Workaround for those still at ITMS 8.8 or earlier.

Recommendation:

  1. Correct binding in IIS manager. Select the site and open Advanced Settings and make sure matches like this:



  2. OR Reinstall IIS on the affected Windows Server.