HCX Alerts: "Unable to publish HCX telemetry. Please check connectivity to vcsa.vmware.com"
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HCX Alerts: "Unable to publish HCX telemetry. Please check connectivity to vcsa.vmware.com"

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Article ID: 410874

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Updated On:

Products

VMware HCX

Issue/Introduction

  • From HCX Manager UI, under Alerts, the following warnings are being observed:
    Unable to publish HCX telemetry. Please check connectivity to vcsa.vmware.com/ph/api/hyper/send/?_v=1.0&_c={collectorId}&_i={instanceId}


  • A similar triggered alarm is also displayed on the vCenter UI:



  • The following error is observed in /common/logs/admin/app.log
    <timestamps> [MetricsCollectionService_SvcThread-40, Ent: HybridityAdmin, , TxId: #######-####-####-####=###########] ERROR c.v.vchs.hybridity.ph.PhConnection- Error uploading the file:/common/upload/metrics/PHONE_HOME/NetworkingLifecycleService/<filename>.json to the Phonehome{"status":"FAILURE","failure":"ConnectTimeoutException","details":"org.apache.http.conn.ConnectTimeoutException: Connect to vcsa.vmware.com:443 [vcsa.vmware.com/#.#.#.#] failed: connect timed out

    <timestamps> UTC [MetricsCollectionService_SvcThread-40, Ent: HybridityAdmin, , TxId: #######-####-####-####=###########] INFO  c.v.vchs.hybridity.ph.PhConnection- vCenter Server alert published for Telemetry communication status, event code: com.vmware.hcx.communication.TelemetryNotReachable , vCenterInstanceId: ########-####-####-####-############


Environment

VMware HCX

Cause

HCX Manager is configured to use the CEIP (Customer Experience Improvement Program) from the appliance management interface at https://hcx-ip-or-fqdn:9443, under Configuration -> Customer Experience Improvement Program; however, HCX is unable to send the information gathered to vcsa.vmware.com.

Resolution

For HCX sites participating in CEIP, perimeter firewalls must allow connections to vcsa.vmware.com. See Network Port and Protocol Requirements.

To test the network connection, open SSH to HCX Manager as admin and run:
curl -kiv https://vcsa.vmware.com
Note: If there is a proxy configured on the appliance management interface at <https://hcx-ip-or-fqdn:9443> under Administration -> Network Settings -> Proxy, ensure the proxy allows this connection.

Workaround:

You can choose to leave the program at any time by selecting an option in HCX Manager interface. For more information, see Leave or Join the HCX Customer Experience Improvement Program.

Note: Leaving the CEIP disables all analytics based programs including the HCX WAN Optimization (WAN-OPT) service. WAN Optimization provides data reduction, compression and line conditioning. Using this service requires participation in the CEIP.

 

Additional Information