Cannot Deploy to CVS Monitor from Workstation
search cancel

Cannot Deploy to CVS Monitor from Workstation

book

Article ID: 410725

calendar_today

Updated On:

Products

Service Virtualization

Issue/Introduction

When trying to deploy test to CVS Monitor directly from Workstation, get the following error:

java.rmi.RemoteException: JMS Messaging problem with ServerRequestHandler for tcp://<short server name>:2010/cvs Could not connect to broker URL: tcp://<short server name>:2010?wireFormat.maxInactivityDuration=0. Reason: java.net.UnknownHostException: <short server name>; nested exception is:

                com.itko.jms.JMSException: Could not connect to broker URL: tcp://<short server name>:2010?wireFormat.maxInactivityDuration=0. Reason: java.net.UnknownHostException: <short server name>

 

Can only deploy cvs on the portal through the mar files.

Environment

All supported DevTest releases.

Windows 2022 on Azure

External database is SQL Server

Cause

The Workstation was not able to find the shortname of the Registry machine, so needed to set the name to the FQDN.  The Coordinator, Simulator and VSE all have their FQDN set.

FQDN - Fully Qualified Domain Name

Resolution

Were able to resolve the issue by changing this property in the RegistryService.vmoptions file

from

-Dlisa.registryName=Ent01-Registry

to:

-Dlisa.registryName=tcp://<FQDN>:2010/Ent01-Registry

The Workstation was not able to find the shortname of the Registry machine, so we needed to set the name to the FQDN.  The Coordinator, Simulator and VSE all have their FQDN set.

1. Brought down all the DevTest services.

2. Deleted the lisatmp_10.8.1 folder.

3. Edited the RegistryService.vmoptions file for the lisa.registryName property change.

4. Rebooted the machine.

5. All components came up with no issues.

6. Restarted the Workstation and was able to deploy the test to CVS Monitor.