Error 'Failed to connect to the server: Connection reset' when performing test connection from Usage Meter
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Error 'Failed to connect to the server: Connection reset' when performing test connection from Usage Meter

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Article ID: 410627

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

  • Usage Meter is not uploading usage data to Broadcom. 
  • Performing 'TEST CONNECTION' from Usage Meter, fails with the following errors:



  • In '/var/log/vmware-um-platform/dss_error.log' on Usage Meter appliance, you notice the  following errors:

    ERROR --- [https-jsse-nio-127.0.0.1-8052-exec-5] c.v.u.d.u.ConnectivityTesterService      : Connectivity test failed with IOException: Connection reset
    java.net.SocketException: Connection reset
            at java.base/sun.nio.ch.NioSocketImpl.implRead(Unknown Source)
            at java.base/sun.nio.ch.NioSocketImpl.read(Unknown Source)
            at java.base/sun.nio.ch.NioSocketImpl$1.read(Unknown Source)
            at java.base/java.net.Socket$SocketInputStream.read(Unknown Source)

  • Performing curl connectivity test from Usage Meter using the following command fails with the following errors:

    usagemeter@UM_hostname [` ]$ curl -v  https://eapi.broadcom.com:443 

    * Host eapi.broadcom.com:443 was resolved.
    * IPv6: (none)
    * IPv4: #.#.#.#
    *   Trying #.#.#.#:443...
    * ALPN: curl offers http/1.1
    * TLSv1.3 (OUT), TLS handshake, Client hello (1):
    *  CAfile: /etc/pki/tls/certs/ca-bundle.crt
    *  CApath: none
    * Recv failure: Connection reset by peer
    * TLS connect error: error:00000000:lib(0)::reason(0)
    * OpenSSL SSL_connect: Connection reset by peer in connection to eapi.broadcom.com:443
    * closing connection #0
    curl: (35) Recv failure: Connection reset by peer

Environment

VMware Cloud Foundation Usage Meter 9.0

Cause

This issue arises due to connectivity issues between Usage Meter appliance and Broadcom portal 'eapi.broadcom.com’ on port 443

Resolution

Usage Meter appliance requires connectivity to portal ‘eapi.broadcom.com’ to send usage data to Broadcom. Firewall and network policies must be reviewed in the environment to establish connectivity to the portal  ‘eapi.broadcom.com’ on port 443.

Additional Information

Usage Meter からの接続テスト実行時に「Failed to connect to the server: Connection reset」エラーが発生する(426335)(Japanese)