Fails to login to Aria Operations for Logs Web Interface
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Fails to login to Aria Operations for Logs Web Interface

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Article ID: 410620

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Updated On:

Products

VMware vRealize Log Insight 8.x

Issue/Introduction

  • When users with a valid username and password might fail to login to Aria Operations for Logs Web Interface. After the username and password are inputted to Web Interface login screen, the main menu of Web Interface can't be shown.
  • You will see similar error in the /storage/var/loginsight/apache-tomcat/logs/catalina.log 
    [https-openssl-apr-###-exec-1] ERROR org.apache.catalina.session.PersistentManagerBase Swapped session [<Sesson_ID>] is invalid

Environment

Aria Operations for Logs 8.16.x
Aria Operations for Logs 8.18.x

Cause

 The issue was caused by incorrect reference counter handling in the specific version of Java Runtime Environment (JRE), referred by LogInsightDaemon process.

Resolution

Broadcom is aware of this issue and plans to include a fix in the Aria Operations for Logs 8.18.6 release. In the meantime, please use the workaround provided below to resolve the issue

Workaround: 

1. Login to the appliance by SSH with root account.

2. Find pid of tomcat process

   ps aux | grep tomcat 

3. Kill tomcat process

    kill <pid of tomcat> 

4. Wait for a few minutes until tomcat process automatically restarted, then try to login again to Web Interfarce.

Note: tomcat is a related process and works with LogInsightDaemon. Restarting tomcat allow triggers LogInsightDaemon restarted.