SRB-RIB Service status shows service status as available but database as down
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SRB-RIB Service status shows service status as available but database as down

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Article ID: 410568

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Updated On:

Products

Network Observability

Issue/Introduction

After upgrading to 24.3.12 we were seeing that the SRM-RIB service status within the NetOps portal was showing available but the SRM database status was showing down.

Environment

DX NetOps 24.3.12

Cause

Database Password  was modified within the 

opt/SRM/srm-rib/webapps/srm-rib/WEB-INF/application.properties

 

Resolution

Please review the Database password within opt/SRM/srm-rib/webapps/srm-rib/WEB-INF/application.properties

rib.minVersion=1.0

rib.currentVersion=1.0

# Spectrum Report Manager Database connection settings

db.queryTimeout=120

db.validationQueryTimeout=3000

db.validationQuery=SELECT 1 FROM DUAL

db.host=****************

db.port=3306

db.database=reporting

db.connection.params=characterEncoding=UTF-8&useSSL=true&verifyServerCertificate=false

db.testOnBorrow=false

db.timeBetweenEvictionRunsMillis=30000

db.maxActive=80

db.username=SRM_user

db.password=************llkkhhrky**( Needs to be encrypted password when db.passwordEncrypted=true)

db.testOnReturn=false

db.passwordEncrypted=true

db.testWhileIdle=true

db.driverClassName=com.mysql.cj.jdbc.Driver

Once the password is corrected , please restart the srm_rib.service.