"Invalid RT VM" appears in Cloud Director Availability for all of a tenant's virtual machines
search cancel

"Invalid RT VM" appears in Cloud Director Availability for all of a tenant's virtual machines

book

Article ID: 410559

calendar_today

Updated On:

Products

VMware Cloud Director VMware Cloud Director Availability - Disaster Recovery 4.x VMware Cloud Director Availability - Migration 4.x

Issue/Introduction

When checking VMware Cloud Director Availability all of a tenant's VMs are marked as "Invalid RT VM" in the UI.

  • In the VMware Cloud Director Availability cloud.log there is an entry for:

    2025-08-18 14:39:58.354 DEBUG - [d1e##########################] [c4-scheduler-1] com.vmware.h4.cloud.service.RtVmService  : Replications [C4-######################,C4-######################] have missing or broken RT VMs.

  • In the Cloud Director vcloud-container-debug.log there is a matching timestamp for:

    2025-08-18 14:39:21,548 | INFO     | task-service-activity-pool-3355 | CalloutManagerImpl             | No active collaboration found for task SYSTEM_FORCE_RECONNECT_VIMSERVER(com.vmware.vcloud.entity.task:#################). | requestId=33d#######################,request=POST https://<Cloud Director FQDN>.com/api/admin/extension/vimServer/########################/action/...,requestTime=###########,remoteAddress=192.###.###.###:####,userAgent=python-requests/2.32.4,accept=application/*+json;version 39.0 vcd=#################,task=################### activity=(com.vmware.vcloud.backendbase.management.system.TaskActivity,urn:uuid:######################)

Environment

VMware Cloud Director 10.6.x
VMware Cloud Director Availability 4.7.3.x

Cause

Within Cloud Director the connection to vCenter was re-connected. This clears in the inventory tables in the Cloud Director database. The virtual machines in Cloud Director as a result will be in a temporary "Unknown" state. Cloud Director Availability checks for the state of the VM every minute. As it's "Unknown" in Cloud Director the VM is also marked as an "Invalid RT VM" in Cloud Director Availability. 

Resolution

Within Cloud Director Availability go to "Incoming Replications", select all VMs in an "Invalid RT VM" state, and then from "All Actions" select "Reconfigure Replication Tracking" and save. The virtual machines will continue replicating if they are valid VMs.