DRS Unable to Migrate VMs to Host After RAM Upgrade in vSAN Environment
search cancel

DRS Unable to Migrate VMs to Host After RAM Upgrade in vSAN Environment

book

Article ID: 410506

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

virtual machines (VMs) fail to migrate to a specific host in a vSAN-enabled cluster following a host RAM upgrade. Despite available resources, DRS attempts to migrate VMs are unsuccessful.

Environment

VMware vSphere 8.0.x

Cause

The vSAN Agent VM on the target host was either powered off, undeployed, or in an invalid state. This agent VM is essential for internal cluster operations such as vSAN File Services and Health Checks.

Attempts to power on the agent VM  failed due to insufficient resources, as indicated in the eam.log:

YYYY-MM-DDTHH:MM:SS |  INFO | vim-inv-update | IssueHandlerBase.java | 116 | Updating issues:
New issues:
 [
eam.issue.HostInMaintenanceMode {
   time = YYYY-MM-DDTHH:MM:SS
   key = 19,
   description = <unset>,
   agency = 'Agency:XXXXX:XXXXXXX-XXXX-XXXX-XXXX-bf91417a01cc:null',
   agencyName = 'vsan-file-services',
   solutionId = 'com.vmware.vsan.health',
   solutionName = 'com.vmware.vsan.health',
   host = 'HostSystem:host-XXXXX:XXXXX:XXXXXXX-XXXX-XXXX-XXXX-85adba3fe44a',
   hostName = 'HOST FQDN',
   agent = 'Agent:XXXXX:XXXXXXX-XXXX-XXXX-XXXX-3fbc72d0fafb:null',
   agentName = 'XXXXX:XXXXXXX-XXXX-XXXX-XXXX-3fbc72d0fafb', <-- host agent name
   vm = 'VirtualMachine:vm-XXXXX:XXXXXXX-XXXX-XXXX-XXXX-85adba3fe44a',
}
]
vpxd.log:    

YYYY-MM-DDTHH:MM:SS info vpxd[06698] [Originator@6876 sub=cdrsPlmt opID=CdrsLoadBalancer-7f751e06] Vm [vim.VirtualMachine:vm-53,XXXXXXXXXX] failed constraint check false on host [vim.HostSystem:host-XXXXX,HOST FQDN] with <obj xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="urn:vim25" versionId="8.0.3.0" xsi:type="LocalizedMethodFault"><fault xsi:type="InsufficientAgentVmsDeployed"><hostName>HOST FQDN </hostName><requiredNumAgentVms>1</requiredNumAgentVms><currentNumAgentVms>0</currentNumAgentVms></fault><localizedMessage></localizedMessage></obj>
YYYY-MM-DDTHH:MM:SS info vpxd[06698] [Originator@6876 sub=cdrsPlmt opID=CdrsLoadBalancer-7f751e06] Vm [vim.VirtualMachine:vm-1021,XXXXXXXXX] failed constraint check false on host [vim.HostSystem:host-XXXXX,HOST FQDN] with <obj xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="urn:vim25" versionId="8.0.3.0" xsi:type="LocalizedMethodFault"><fault xsi:type="InsufficientAgentVmsDeployed"><hostName>HOST FQDN
</hostName><requiredNumAgentVms>1</requiredNumAgentVms><currentNumAgentVms>0</currentNumAgentVms></fault><localizedMessage></localizedMessage></obj>
YYYY-MM-DDTHH:MM:SS info vpxd[06660] [Originator@6876 sub=pbm opID=CdrsLoadBalancer-7f751e06-513b89a6-01-01] migrate callback is skipped for same-VC migration - Home and all disks and profiles are the same
YYYY-MM-DDTHH:MM:SS info vpxd[06660] [Originator@6876 sub=VmProv opID=CdrsLoadBalancer-7f751e06-513b89a6-01-01] Local-VC Host Migrate of poweredOn VM 'uspa-smokeping' (vm-XXXX, ds:///vmfs/volumes/vsan:5298e9df3c5cfe48-980a687462f466e4/2aa43765-04d2-30b9-91ca-3ceceffb64b8/uspa-smokeping.vmx) on host-XXXXXX (x.xx.141) in pool resgroup-9 with ds ds:///vmfs/volumes/vsan:5298e9df3c5cfe48-980a687462f466e4/ to host-XXXXX (x.x.x.x) in pool resgroup-9 with ds ds:///vmfs/volumes/vsan:5298e9df3c5cfe48-980a687462f466e4/ with migId 3915703760353475931 as Operation: Local-VC_DRS_NonMM_ComputevMotion
YYYY-MM-DDTHH:MM:SS info vpxd[06660] [Originator@6876 sub=VmCheck opID=CdrsLoadBalancer-7f751e06-513b89a6-01-01] CompatCheck results: (vim.vm.check.Result) [
-->    (vim.vm.check.Result) {
-->       vm = 'vim.VirtualMachine:XXXXX:XXXXXXX-XXXX-XXXX-XXXX-85adba3fe44a:vm-XXXX',
-->       host = 'vim.HostSystem:XXXXX:XXXXXXX-XXXX-XXXX-XXXX-85adba3fe44a:host-XXXXX',
-->    }
--> ]

Resolution

To resolve the issue, perform the following steps:

  1. Place the affected host (srv46) into maintenance mode.

  2. Exit maintenance mode once completed.

This action triggers vSphere to redeploy the required vSAN Agent VM, restoring compliance with DRS constraints and vSAN health checks. Once the agent VM is active, DRS resumes normal operation and VM migrations succeed.