Unable to upload VMware Tools to the Depot Error: A general system error occurred: A depot is inaccessible or has invalid contents. Make sure an official depot source is used and verify connection to the depot.
search cancel

Unable to upload VMware Tools to the Depot Error: A general system error occurred: A depot is inaccessible or has invalid contents. Make sure an official depot source is used and verify connection to the depot.

book

Article ID: 410471

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

In environments where vSphere Lifecycle Manager (vLCM) images/baselines are not connected to the internet, VMware Tools packages must be imported offline.

However, when attempting to import the VMware Tools package, the operation fails with the following error:

A general system error occurred: A depot is inaccessible or has invalid contents.
Make sure an official depot source is used and verify connection to the depot.

 

Environment

VMware ESXi 7.x

VMware ESXi 8.x

Cause

The offline ZIP bundle being imported is incorrect or corrupted.

The downloaded package may not match the expected format required for Lifecycle Manager.

Resolution

  • Login to the Broadcom Support Portal.
    • Navigate to the VMware Tools release notes for your version.
    • From the release notes, use the product download hyperlink to download the correct offline ZIP bundle.
    • Once downloaded, import the correct ZIP into Lifecycle Manager.
  • This time, the upload should succeed without errors.

Based on your environment setup:

  • If you are using baselines, create or update the baseline to include the VMware Tools package.
  • If you are using images, edit the image components to add the VMware Tools package.