The newly added extent is not visible to expand the datastore from vCenter
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The newly added extent is not visible to expand the datastore from vCenter

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Article ID: 410468

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptom:

  • After adding a new extent to the ESXI to increase a datastore, the new extent LUN is not visible when trying to expand from the vCenter UI.
  • LUN is visible from the list of Storage Devices on the ESXi host UI

vobd.log

2025-09-09T06:22:18.764Z In(14) vobd[2097954]: [vmfsCorrelator] 731573094us: [vob.vmfs.extent.offline] An attached device naa.***************:1 file system [********, ********-********-****-************] is now in a degraded state. While the datastore is still available, parts of the data that reside on the extent that went offline might be inaccessible

Environment

VMware vSphere ESXi 7.x
VMware vSphere ESXi 8.x

Cause

  • One of the hosts, which was recently added to the cluster, does not see the newly added extent.
  • Since the extent LUN was not visible on all the hosts in the vCenter/cluster, the datastore expansion from the UI was not able to detect the LUN.

Resolution

 

  • Verify whether the device is listed on the ESXi host by running the following command from the host CLI:

    esxcli storage core device list
  • If the extent does not appear, advise the customer to engage their internal SAN team to review and validate the zoning configuration.