After rebooting NSX Manager, Monitoring-System dashboard and Search functionality from GUI does not work.
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After rebooting NSX Manager, Monitoring-System dashboard and Search functionality from GUI does not work.

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Article ID: 410465

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Updated On:

Products

VMware NSX

Issue/Introduction

  •  The Search function in NSX Manager GUI does not work as expected.
  • 'Home > Monitoring - System' dashboard may not load data or is unavailable.
  • Logs similar to below can be found in /var/log/policy/policy.*
    2025-08-20T09:09:00.724Z ERROR pool-1324-thread-1 UfoGenericConverter 88416 - [nsx@6876 comp="nsx-manager" errorCode="MP60511" level="ERROR" subcomp="manager"] [Indexing: DtoConversion] Could not convert UFO object to Dto by DTO converter UfoObject{operationType=CREATE, descriptor=IndexingTypeDescriptor{tableName='ServiceConfig', streamTag=MANAGER}, identifier=uuid {
      left: 1182####2100####3434
      right: 1327####2304####2308
    }

Environment

NSX 3.2.3.1

Cause

The issue is caused by stale entries in ServiceConfig table, where the ServiceConfig record was not deleted when deleting the Tier-0 (Logical Router). As 'Search' is designed to have strong consistency with primary data source, Corfu doesn't serve stale data to UI.

In addition, Logical Router data is not available in Corfu tables for the given ServiceConfig entry and as a result 'ServiceConfigConverter.toDtoWithTx' can't convert model to DTO.

Resolution

This issue is fixed in 4.2.1 and above releases.

Workaround:
Delete stale entry from ServiceConfig table. As this involves Corfu Database edit, it is recommended to create a Broadcom Support case.