WARNING: Unable to process SMSESSION cookie in Web Agent
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WARNING: Unable to process SMSESSION cookie in Web Agent

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Article ID: 41040

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On SITEMINDER CA Single Sign On Agents (SiteMinder)

Issue/Introduction

The Web Agent is unable to process SMSESSION cookie and the agent trace log shows this message:

"SMSESSION cookie is custom from a third party and not accepted"

 

Environment

Symantec SiteMinder Web Agents R12.52 ANy and R12.8 Any

 

Cause

The log message means the session cookie was generated by a custom SDK agent but the agent that is consuming/validating the session cookie didn't have the proper
configuration to handle the custom cookie.

 

Resolution

Set AcceptTPCookie to YES in the Agent Config Object (ACO) for all the agents that will be validating the cookie that was generated by custom SDK.

Note that:

- Session spec in the session cookie will have some information to
  identify how this session was created (either by SDK or Web Agent).

- The Agent uses this information along with the AcceptTPCookie
  setting to validate a cookie that was generated by a custom SDK.

- In a multi Agents environment, AcceptTPCookie must be set to YES in
  all agents that need to validate the cookie that was originally
  generated by SDK.