Problem with Backspace in nf.htmpl
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Problem with Backspace in nf.htmpl

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Article ID: 410378

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Updated On:

Products

CA Service Desk Manager ServiceDesk CA Service Management - Service Desk Manager

Issue/Introduction

After upgrade to SDM 17.4 RU4, the “Backspace” button does not work within the HTML Text Box in the “nf.htmpl” form, and to delete part of the text, you can only use the “Delete” button. We confirmed the post-installation tasks were successfully completed, as documented, for “HTML Tags Sanitization” and “Enable HTML content for Ticket Description in the Activity log.” We tried restarting the service and ran new tests, but the problem persists.

Environment

Service Desk Manager 17.4 RU4

Cause

We checked the environment and found there was a copy of the nf.htmpl form in the user's <SDM installation>\site\mods folder. In testing SDM 17.4 RU4 "out of the box" we could not reproduce the problem.  However, wheh we received a copy of the user's "...\site\mods" folder and added that to our testing server, we could reproduce the problem.  We concluded the problem must be related to customizations to the form.

Resolution

While providing support for customizations to Service Desk is beyond the scope of the support team, we do have articles and information that can help to troubleshoot such problems during or immediately after an upgrade.  In particular,

Customization Not Working After the Upgrade

There is also a Customization Upgrade Utility provided with Service Desk that can help transition customizations to the new version. 

Some other troubleshooting tips might include:

A way to identify the root cause is a customization is to do the following:

  • Make a backup copy of the <SDM Installation>\site\mods folder by copying it to another location on the computer, then deleting all the content from that folder.
  • Restart Service Desk
  • Clear the Service Desk web cache with the command "pdm_webcache -H -b"
  • Clear the browser cache
  • Test to see if the problem is still there.

Something else to consider is that web forms can use custom javascript to perform some of their functionality.  Look for any javascript "includes", locate and review that code as well.  For example:

As always, it is highly recommended to test any upgrade between versions of Service Desk or even applying a new RU patch in a test environment first, and test thoroughly all customizations so that any problems can be resolved before applying the same patch or upgrade in the production environment.