SPE rest API /spe/api/v1/product-status lists <isLicensed> as false when the license is still valid
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SPE rest API /spe/api/v1/product-status lists <isLicensed> as false when the license is still valid

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Article ID: 410306

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Updated On:

Products

Protection Engine for Cloud Services

Issue/Introduction

When using the /spe/api/v1/product-status Rest API in SPE, the <isLicensed> sections reports that the SPE license is false even though the license is still valid.

Environment

Symantec Protection Engine

Cause

The license is valid for less than 60 days.

Resolution

An issue with the /spe/api/v1/product-status Rest API in SPE is under investigation.

Workaround:

The license status can be confirmed by looking the <Licensing> section of report.xml.  This file can be found in

  • Windows: C:\Program Files\Symantec\Scan Engine\report.xml
  • Linux:  /opt/SYMCScan/bin/report.xml

If the report.xml shows the license is still valid it can continue to be used normally.

Additional Information