Unable to add SPE to console after upgrade to SPE 9.2.1
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Unable to add SPE to console after upgrade to SPE 9.2.1

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Article ID: 410304

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Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

After upgrading to Symantec Protection Engine (SPE) 9.2.1 you are unable to re-add the SPE to the SPE console due to the following error:

<Server Name> Reason: Unauthorized

You also see the following in the CmafUI.log:

[Main UI Thread] INFO  Symantec.Cmaf.Security.AuthManagerHelper - Successfully executed the Create User REST API with user: MgmtUser##########
[Main UI Thread] INFO  Symantec.Cmaf.Security.BasicAuthManager - Response code of Create User Rest api is : BadRequest

Environment

SPE 9.2.1

SPE Console 9.2.1

Cause

During the upgrade the MgmtUser was not correctly auto-removed.

Resolution

  1. Open the CLI on the SPE server
  2. Stop the SPE Rest API service
    • Linux
      /etc/init.d/symsrestapiservice stop
    • Windows
      net stop "Symantec Protection Engine REST API"
  3. Change to the Rest API folder
    • Linux
      cd /opt/SYMCScan/RestAPI
    • Windows
      cd "\Program Files\Symantec\Scan Engine\RestAPI"
  4. Edit the file restconfiguration.xml
  5. Add a "1" to the end of the mgmtuser username (see example below) and save the file:
    <user role="management" loginname="MgmtUser#########" displayname="MgmtUser#########1" password="[REDACTED]" emailid=""/>
  6. Restart the Rest API service
    • Linux
      /etc/init.d/symsrestapiservice start
    • Windows
      net start "Symantec Protection Engine REST API"
  7. Add the SPE server to the SPE console