Unable to see tenant or assign licensing to tenants in the VMware Cloud Foundation Business Service Console
search cancel

Unable to see tenant or assign licensing to tenants in the VMware Cloud Foundation Business Service Console

book

Article ID: 410280

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

When working in the VMware Cloud Foundation Business Service Console (VCF BSC) as a VMware Cloud Service Provider (VSCP), the following issues are present:

  • Expected tenants are not visible

  • Trying to create a new tenant for licensing is not working

  • Acquired licensing is not displaying under the expected tenant

Cause

There are a couple of issues that could be going on such as:

  • The default tenant might not be correct

  • There might be multiple tenants (including system generated tenants), that the licensing may have been associated with

  • The license has not been split in order to share with other tenants

Resolution

Below is how to solve each of the above issues:

Change the default tenant:

This is set at a per user level. In order to change this switch to the desired tenant from the left hand tenant drop down selector. Select the checkbox: Set as Preferred Tenant.

Split the license to share with other tenants:

Prerequisite: Look through all available tenants and identify which tenant the licensing has been associated with.

  1. Switch to the previously identified tenant that the licensing has been associated with.
  2. Go to License Management > Licenses > Manage Licenses (Split / Merge)
  3. Select Product > Create > (in the new record) add name, capacity  (This creates the new split license with the provided name and capacity).
  4. Search the newly created split license under Licenses
  5. Click on the 3 dots to the left of the record > Share with Another Tenant > Select the desired Tenant to share with

Additional Information