Duplicate entries are found for metrics in the UIM database
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Duplicate entries are found for metrics in the UIM database

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Article ID: 410279

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Checking the database data_engine logs shows two duplicate entries for each of these metrics (timestamp, value, nimid, etc are all replicated):

Aug 29 12:28:10:897 [5352] 2 de: HandleMessage: Insert Data - nimid: PD66962398-23309     (2025-08-29 12:28:09) table_id:     414266 value=        52.50 time: 2025-08-29 12:28:09  qos=QOS_DISK_USAGE_PERC  source=<ROBOTNAME> target=C:\                    
Aug 29 12:28:10:908 [5352] 2 de: HandleMessage: Insert Data - nimid: PD66962398-23309     (2025-08-29 12:28:09) table_id:     414266 value=        52.50 time: 2025-08-29 12:28:09  qos=QOS_DISK_USAGE_PERC  source=<ROBOTNAME> target=C:\ 

 

RN tables show duplicate entries: 

DrNimbus only shows one QOS_MESSAGE in the queues on the primary hub.

This occurs for metrics from many, if not all, robots.

Environment

  • UIM 23.4

Cause

This issue can be caused by having more than one queue between hubs for the QOS_MESSAGE subject.  This causes the message to be duplicated, but DrNimbus will only show one QOS_MESSAGE in the queues on the primary hub.  

Resolution

  • Identify the hubs where you have more than one queue with the QOS_MESSAGE subject.
    • Note that the wildcard * subject will also have the QOS_MESSAGE subject included
    • If you have a multi-tiered hub structure, you may need to check the entire path from the affected robots to the primary hub (or hub where the data_engine is running).
  • Deactivate the attach and get queues on both of the hubs.
    • Delete these queues when you confirm the problem is resolved.