How to keep session when open link from notification Service Desk
search cancel

How to keep session when open link from notification Service Desk

book

Article ID: 410270

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog

Issue/Introduction

Analysts have an open SDM login (session created). If the same analyst opens a CA SDM link from an email notification, this new tab asks for login credentials again. It won't use the current open session.

This issue does not occur in Service Catalog.

Environment

Service Desk Manager 17.x - Basic Authentication

Service Catalog 17.x - Basic Authentication

Cause

This is not possible when using Basic Authentication because SDM alone doesn't rely on any browser cookies to retain the session information. SDM and Service Catalog have different behaviors. While SDM alone doesn't rely on browser cookies to retain the session information, Service Catalog does rely on browser cookies (JsessionID is the cookie name), which is why you see differences.

Resolution

This will be possible when using SSO authentication in the SDM environment. To configure SDM with SSO authentication, refer to the following link:

Enable SAML Authentication for CA SDM