"Error connecting Fleet management node, try again" when connecting Fleet Management to VCF Operations
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"Error connecting Fleet management node, try again" when connecting Fleet Management to VCF Operations

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Article ID: 410260

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Updated On:

Products

VCF Operations

Issue/Introduction

  • VMware Cloud Foundation Operations admin interface -> connect Fleet management shows this error: "Error connecting Fleet management node, try again".

  • The Option to delete Operations is greyed out when navigating to Fleet Management > Lifecycle > Components in the VCF Operations UI

  • Additionally, on the Fleet Management appliance, running cat /etc/resolv.conf  command confirmed that the required DNS server entries were missing

  • The following error is seen in /var/log/vrlcm/vmware_vrlcm.log on the Fleet Manager appliance
    ERROR vrlcm[##] [http-nio-8080-exec-##] [c.v.v.l.l.c.EnvironmentController] – Exception while creating Environment : com.vmware.vrealize.lcm.lcops.common.exception.InvalidEnvironmentException: Deployment or Import Blocked: You’ve reached the limit of allowed instances for VCF Operations (maximum: 1). Please check your inventory and remove any existing deployed, failed or draft instance(s) to proceed with the new deployment or import.

Environment

  • VCF Operations  9.x
  • VCF Operations Fleet Management 9.x

Cause

VCF Operations Fleet Manager can lose connection to VCF Operations when upgrading or if there are network, NTP, or DNS issues present

Resolution

If DNS entries are missing on the Fleet Manager appliance, follow the steps below to update them, and contact Broadcom Technical Support for assistance in resolving the reported issue, referencing this KB article

Prerequisite: Take an Offline Snapshot

Before making any changes, ensure you take an offline snapshot of the Fleet Management appliance Virtual Machine to prevent potential issues during the update.

Steps to Set DNS Server IP Address

  1. Login to Fleet management Appliance 

    SSH into the Fleet management Appliance Manager using the root account.
  2. Update DNS Server IPs

    Run the following command:

    nmctl set-dns dev eth0 dns DNS_Server_1,DNS_Server_2

    Note : Replace DNS_Server_1 and DNS_Server_2 with the IP addresses of your primary and secondary DNS servers.

Verification

  1. Check /etc/resolv.conf

    Verify that the DNS servers have been updated by running:

    cat /etc/resolv.conf

    This file should list the updated DNS server entries.

  2. Restart Network Name Resolution Service

    Apply the DNS changes by restarting the service:

    sudo systemctl restart systemd-resolved.service

    This will restart the service and apply the updated DNS configuration.

Additional Information