Unable to access Aria Operations for Logs UI
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Unable to access Aria Operations for Logs UI

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Article ID: 410221

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Aria Operations for Logs may become inaccessible, and nodes may appear as 'Down' when checked using the command: 'nodetool-no-pass status'.
  • Error messages similar to the following appear in /storage/core/loginsight/var/cassandra.log file when starting Log Insight Daemon service:
    ERROR [main] 2025-09-11T13:04:49,477 CassandraDaemon.java:900 - Port already in use: 7199; nested exception is:
            java.net.BindException: Address already in use (Bind failed)
    java.net.BindException: Address already in use (Bind failed)
            at java.net.PlainSocketImpl.socketBind(Native Method) ~[?:?]
            at java.net.AbstractPlainSocketImpl.bind(Unknown Source) ~[?:?]
            at java.net.ServerSocket.bind(Unknown Source) ~[?:?]
            at java.net.ServerSocket.<init>(Unknown Source) ~[?:?]
            at javax.net.DefaultServerSocketFactory.createServerSocket(Unknown Source) ~[?:?]

Environment

VMware Aria Operations for logs 8.x

Cause

This issue is typically caused by time synchronization discrepancies between Aria Operations for Logs nodes. Even a small time drift—typically greater than 2 seconds—can lead to instability in the Cassandra database cluster. Such inconsistencies may trigger race conditions, where nodes fail to start properly or become unresponsive, ultimately impacting database operations and UI availability.

Resolution

Verify NTP Synchronization: Ensure that all appliance VMs can successfully communicate with and synchronize time from the configured NTP servers.:387888

Workaround:

If there is time drift with NTP server, follow the below steps:

1. Place all the Aria Operations for logs nodes on the same ESXi host.

2. Enable Time Synchronization with Host:

For each VM:

  • Go to VM Edit Settings > VM Options

  • Enable the following options:

    • Synchronize at startup and resume

    • Synchronize time periodically

3. Run the below command on each node to ensure system time is consistent and synchronized:

watch 'date'

4. Restart the loginsight service in the below order:

a. Stop the loginsight service on all worker nodes first, followed by the primary node using the below command:

service loginsight stop

b. Once all services are stopped, start the loginsight service on the primary node first, and then on each worker nodes, using the below command:

service loginsight start

5. Use the following command to confirm that all nodes are reporting UP/Normal:

'nodetool-no-pass status'

6. Log in to the Aria Operations for Logs UI and perform the checks.