After upgrade, some users have Authentication errors on a specific browser
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After upgrade, some users have Authentication errors on a specific browser

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Article ID: 410131

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After Clarity Upgrade or patch, some users see errors "[en - Error occurred, please contact system administrator'] in UI on Edge only and here is the error in the logs: 
 
 
ERROR 2025-09-09 21:38:13,493 [http-nio-XXXXXXX-exec-1] security.AuthenticationService (clarity:unknown:222481671__E4050286-DD14-4980-82EB-E0606E0F3872:PPM_REST_API) (9df907b9-024d-41b7-bd0c-9faba6586e78) AuthenticationService ::  found cookie[value=222481671__E4050286-DD14-4980-82EB-E0606E0F3872] but either the session is invalid or user could not be logged-in. Deleting the user session cookie.
ERROR 2025-09-09 21:38:13,493 [http-nio-XXXXXXXX-exec-1] ppm.rest (clarity:unknown:222481671__E4050286-DD14-4980-82EB-E0606E0F3872:PPM_REST_API) (9df907b9-024d-41b7-bd0c-9faba6586e78) AuthenticationFilter ::  Exception while authenticating user.
com.niku.union.security.SecurityException: Authentication Failure Error!
at com.ca.ppm.rest.security.AuthenticationFilter.doFilter(AuthenticationFilter.java:143)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:168)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:144)
at com.ca.ppm.rest.security.APIAccessibilityFilter.doFilter(APIAccessibilityFilter.java:114)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:168)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:144)
at com.niku.union.web.filter.OIDCFilter.doFilter(OIDCFilter.java:377)

Environment

All Supported Clarity Releases

Cause

Prefilled password in the browser is causing this

Resolution

Make sure there is no prefilled password in your browser:

Edge:

  1. Three dots menu – Settings - Passwords and Autofills – Microsoft Password Manager
  2. See if you have prefilled password for Clarity or SSO in Clarity – if yes, delete it
  3. Make sure you have no passwords for Clarity URL in that list
  4. Restart the browser and try again to access Clarity
  5. If asked to save the password say Never 

For Chrome:

  1. Three dots menu – Passwords and Autofills – Google Password Manager
  2. See if you have prefilled password for Clarity or SSO in Clarity – if yes, delete it
  3. Make sure you have no passwords for Clarity URL in that list
  4. Restart the browser and try again to access Clarity
  5. If asked to save the password say Never