Not able to log into TAC Portal (Tanzu Application Catalog - Access Denied)
search cancel

Not able to log into TAC Portal (Tanzu Application Catalog - Access Denied)

book

Article ID: 410128

calendar_today

Updated On:

Products

VMware Tanzu Application Platform VMware Tanzu Application Catalog VMware Tanzu Application Service

Issue/Introduction

You try to log into TAC portal and get "Access Denied" message on TAC (Tanzu Application Catalog) Portal Dashboard:

Cause

The user is missing org access.  A common reason for this issue to occur is that the user is properly authenticated, but not properly authorized. 

Resolution

Users must explicitly be given access to the org where TAC is running. This goes for both federated and non-federated logins.  

 

For federated (Enterprise SSO):

  • Customer idP handles the user authentication, however authorized users are handled via CSP (VMware Cloud Services Platform).
  •  Add the user to the org where TAC and CSP is running and assign the appropriate roles (ie. Admin, Viewer, etc.)

For non-federated logins (VMware Cloud Services account):

  • Similar to federated login, the user will need to be explicitly invited by org admin to the org where TAC /CSP is running.  The user will also need to accept the invite for access.