Problem:
After installing a new APM MQ Agent, the total enqueue/dequeue counts reported are too low.
Environment:
Any version of IBM MQ being monitored by multiple monitoring applications or any version of APM MQ Agents
Cause:
Multiple applications monitoring MQ enqueue/dequeue counts will actually interfere with each other. These counts are cleared by MQ after they are reported to the monitoring application. As a result, each monitoring application can only get part of the true count.
Resolution:
Do not have multiple APM Agents (or APM and another application) try to monitor MQ at the same time. One of the monitoring applications (or APM Agents) should be disabled