Security Token Service (STS) URL returns 404 error

book

Article ID: 40984

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

Issue: 

Accessing the STS URL results in a 404 error in Internet Explorer:

https://{caaccessgateway-domainName}/{CA-Single Sign-On-PartnershipName}/ws-username

Initialization completes successfully based on the logs. But the browser does not return the response:

 

WS-Trust is available only via SOAP request

Environment:  

Policy Server: R12.52 SP1 and above

Secure Proxy Server: R12.52 SP1 and above

Cause:

 

“Show Friendly HTTP Error Messages” is enabled in the Internet Explorer settings.

Resolution: 

Navigate to the Internet Options for Internet Explorer. Uncheck the “Show Friendly HTTP Error Messages” in the Advanced tab.

Close the browser, open a new one and access the "https://{caaccessgateway-domainName}/{CA-Single Sign-On-PartnershipName}/ws-username" URL again. The page will display without errors.

 

Environment

Release:
Component: SMFED