Jobs are getting stuck in ACTIVE/READY state
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Jobs are getting stuck in ACTIVE/READY state

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Article ID: 40982

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent CA Workload Automation DE

Issue/Introduction

Jobs are getting Stuck in  READY/ACTIVE state and not working even after restarting system agent

Environment

CA Workload Automation Agent Unix Environments

Version R11.x, R12

Cause

The spool file contained the following error

cybspawn: unable to obtain the message queue ID. errno:13 Reason: The file access permissions do not allow the specified action.

The problem was due to the fact that the /opt/CA did not have valid permissions for the world

drwxr-x--- 6 root system 256 Apr 12 18:12 /opt/CA 

The ‘/opt/CA’ is a folder and it needs execute permission to be browsable

x bit for directory is also called as search bit. Actually, it enables you to access the inodes of the files listed inside the folder. So if you want to access spool folder then you must have search access on every parent folder.

 

 

Resolution

Grant execute permission for folder  /opt/CA to avoid any execute restriction

chmod 755 /opt/CA 

Additional Information

Please refer the following link for additional information on file and folder permissions

https://www.ibm.com/support/knowledgecenter/ssw_aix_71/com.ibm.aix.cmds1/chmod.htm