Uptime returned by third-party toll does not match with the actual uptime of NSX manager/edges
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Uptime returned by third-party toll does not match with the actual uptime of NSX manager/edges

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Article ID: 409722

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Updated On:

Products

VMware NSX

Issue/Introduction

  • The actual uptime of NSX manager is seen as followed:
  • The uptime returned by third-party tool is as followed:
  • The uptime returned by command 'systemctl status snmpd' or 'systemctl status vmware-snmpd' is also different then the actual uptime of NSX manager/edge.

Environment

VMware NSX

Cause

The  "systemctl status snmpd" or "systemctl status vmware-snmpd" just shows the active time for OS level service/process. Output of this command just shows the re-initialized time of SNMP agent. 

If there were any changes made in the SNMP config, SNMP agent will be re-initialized as well(but without OS level service/process restart).

Resolution

There is no OID present for SNMP agent in NSX-T to monitor the uptime of manager/edges.

Hence, the uptime of NSX manager/edges cannot be monitored through any third-party tool.

Additional Information

Refer below KB article to determine the MIB module listing, name, and type of an SNMP OID:-

https://knowledge.broadcom.com/external/article?articleId=313524