JVM Error in the SSO Policy Server trace logs.
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JVM Error in the SSO Policy Server trace logs.

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Article ID: 40946

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

Problem: 

With the agent for SharePoint during the Claims (Federation) transaction, the following error is seen in the SSO Policy Server Trace Logs.

[04/13/2016][13:50:26][13:50:26.903][][][][][][4562][3610782608][][][][][][][][][][SmJVMSupport.cpp:472][][][][][][][][][][][][][][][][][][][][][][][][][][][][LogMessage:ERROR:[sm-JavaApi-00960] SmJVMSupport: Error creating JVM - JNI code: -6(JNI_EINVAL)][][][][][][][][][]

Environment:  

Single Sign On
Federation
SSO Agent For SharePoint

Cause: 

In this case, we found that the JVM process would not start during the federation transaction. Looking at the configuration for JAVA on the policy server, JVMOptions.txt file, we found that the memory settings were set to high values of Xms4096m and mx4096m.

Resolution/Workaround:

  1. Backup the JVMOptions.txt
    \CA\siteminder\config
  2. Change the configuration values for memory to a lower value. 
    Example: We used the following settings. 
    Xms1024 
    Xmx1536
  3. Restart the policy server process if the setting do not take effect on the next federation transaction 

Environment

Release: SOASMU99000-12.5-SOA Security Manager-Upgrade
Component: