‘Incomplete Collection’ error while collecting data from vCenter, including SRM objects, in the Usage Meter UI
search cancel

‘Incomplete Collection’ error while collecting data from vCenter, including SRM objects, in the Usage Meter UI

book

Article ID: 409451

calendar_today

Updated On:

Products

VMware Usage Meter

Issue/Introduction

Usage meter notifications tab display the following error:

“Partial VC collection failure at stage: SRM. SRM collection failed on server 9 due to Collection error: Unknown Failure. No permissions to log into SRM :: https://<SRM-FQDN:443/drserver/vcdr/extapi/sdk. Permission to perform this operation was denied.”

Environment

VMware Cloud Foundation Usage Meter 9.0.1

Cause

The user had not been added to the SRM configuration, blocking access to the SRM plugin in vCenter. Additionally, the user account being used lacked the necessary permissions to log into SRM, resulting in incomplete data collection since the retrieval of SRM data could not be completed.

Resolution

Update the SRM configuration by adding the appropriate user and assigning the correct role, so that the SRM plugin is accessible from vCenter.

Refer to: Assign Site Recovery Manager Roles and Permissions