vSphere Supervisor node shows Spherelet agent on an older version
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vSphere Supervisor node shows Spherelet agent on an older version

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Article ID: 409411

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Updated On:

Products

VMware vSphere Kubernetes Service

Issue/Introduction

This KB will serve as a landing point for customers who need assistance updating the Spherelet agent version on one or more Supervisor hosts.

Example scenario:

  • Your Supervisor Kubernetes version is 1.28.x.  All but one ESXi host has those spherelet agent versions (1.28.x).  One has 1.27.x.

  • One of the Spherelet agent versions is showing 1.27.x.

    You show this by running the following command from the Supervisor context:

    kubectl get nodes

Example output:

NAME                               STATUS   ROLES                  AGE    VERSION
################################   Ready    control-plane,master   309d   v1.28.3+vmware.wcp.1
################################   Ready    control-plane,master   309d   v1.28.3+vmware.wcp.1
################################   Ready    control-plane,master   309d   v1.28.3+vmware.wcp.1
######.######.local                Ready    agent                  309d   v1.28.2-sph-5111a65
#####.######.local                 Ready    agent                  309d   v1.28.2-sph-5111a65
#####.######.local                 Ready    agent                  309d   v1.28.2-sph-5111a65
#####.######.local                 Ready    agent                  309d   v1.27.X-XXX-XXXXXXX

 

 

NOTE: This needs to be resolved before upgrading the vSphere Supervisor. 

Environment

vSphere Kubernetes Service

Cause

The specific root cause needs to be determined through Broadcom Support and VKS Engineering.

Resolution

  • Collect a "Full" ESXi Diagnostic bundle for the specific ESXi host.

Refer to KB 319493: Collecting diagnostic information for VMware ESXi using vSphere Client

  • Collect the Support Bundle for a Supervisor 

  • Open a new Broadcom Support case for the vSphere Kubernetes Service product

  • In the Broadcom Support case, make sure to reference this KB number: 409411

  • Attach the ESXi diagnostic information to the case
  • Attach the Supervisor Support bundle to the case

 

A Broadcom Support Engineer will be able to reference the internal procedure, which is referenced within this KB to:

  • Correct the Spherelet version

  • Perform the root cause analysis