Client upgrade to 14.5.01 didn't work
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Client upgrade to 14.5.01 didn't work

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Article ID: 409390

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Updated On:

Products

CA Harvest Software Change Manager CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

After applying the 14.5.01 cumulative patch for the SCM Client, if I check in Control Panel -> Programs -> View installed updates, it says the 14.5.01 patch is installed.  However, in Workbench, if I check the Help -> About window it says the version is 14.5.0.45.  In addition, all the known problems that should have been fixed by the cumulative patch are still broken.  What happened?

Environment

Harvest Software Change Manager v14.5.01

Cause

If some interim efixes were appliled to the SCM 14.5.0 client, in some cases, the 14.5.01 cumulative patch will not install correctly.

Resolution

It is recommended to uninstall all SCM components on the workstation, delete the %CA_SCM_HOME% folder, and install again, first 14.5.0 client, then the 14.5.01 cumulative patch.

After successful installation, the Workbench's Help -> About window should show version 14.5.01.204

Additional Information

There is a way to build a script that can complete this process for you more simply and easily in a single step.  See article "Install 14.5 and 14.5.01 patch for SCM Client in one step"

The SCM 14.5.01 cumulative patch can be obtained from the Broadcom Support Download Center: CA HARVEST SCM CUMULATIVE PATCH V14.5.01

If uninstalling all Harvest components and reinstalling is not possible, a script can be provided that resolves the problem without uninstalling.  Please contact support.

The above-described problem applies only to the Full Client installation that includes both the Administrator Tool and Workbench.  The SCM 14.5.01 cumulative patch for the SCM Workbench-Only installation completes successfully, even if interim efixes were applied.