Unable to login to VCF Automation using AD user. It fails with error: "Your Single Sign-On attempt failed"
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Unable to login to VCF Automation using AD user. It fails with error: "Your Single Sign-On attempt failed"

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Article ID: 409284

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • VCF Automation has been configured to use VCF SSO for authentication. The deployment mode is set to embedded. However, after this configuration, attempts to log in to VCF Automation result in the following error: "Your Single Sign-On attempt failed"

 

Environment

VCF Automation 9.0

Cause

Incorrect UPN format added while importing user/group

Resolution

  1. Log in to the VCF provider Portal
    Use an account with administrative privileges.

  2. Navigate to the Access control Section

    • Go to Administration > Access control

  3. Import User

    • Select Import User.

    • Select VCF SSO
    • In the username field, enter the UPN format:

       
      username@domain
  4. Assign Role to User

    • After adding the user or group, assign the appropriate role based on required access level

    • Save the changes.

  5. Log Out of the Current Session

  6. Log In Using VCF SSO as the Newly Added User

    • Use the same UPN credentials to log in via VCF SSO.

    • Confirm that the assigned role permissions are active.

Note: The above steps apply to both users and groups. Ensure that the group names are also provided in the correct UPN format (groupname@domain) and assigned suitable roles during import.